import Foundation
let pattern = #"(?<=<p>).*?(?=<\/p>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"replace me"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)