use strict;
my $str = 'Nissan
nissan
<span>Nissan</span>
<a href="nissan.com">Nissan</a>
<a href="nissan.com"><span>Nissan</span></a>
Company Nissan is a name. and Nissan Micra is model name.
Company <a href="nissan.com"><span>Nissan</span></a> is a name. and Nissan Micra is model name.
This is new <a href=\'https://www.url.com\'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>
<p>Company Nissan is a name Company Nissan is a name. Company Nissan is a name and <a href=\'www.nnm.be\'><main>New Nissan Micra</main></a> is model name.</p>
<a>nissan </a>
<a>nissan
</a>
<a>nissan<span></span><a>
<a foo="nissan" bar="<">text<a>';
my $regex = qr/[Nn]issan(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\n))*</(?:a|span)>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}