import Foundation
let pattern = #"^-?(((([0][0-9])|([1][0-3])):(([03][0])|([14][5])))|14:00)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
00:00
01:00
00:15
00:30
00:45
01:30
04:00
05:00
06:30
10:00
13:00
14:00
13:30
14:30
20:00
24:00
-14:00
-13:30
-10:00
-09:00
-00:00
00:10
00:20
00:25:
00:35
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)