package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(["].*?["])|([[:alnum:]_\$]+)`)
var str = `HELLO VERSION MIN=$min MAX=$max USER="xxx" PASSWORD="yyy"
FIRST SECOND ARG1=$value ARG2="with space"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}