import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?:ht|f)tps?:\\/\\/|www)[^\\s,?!]+(?!.*<\\/a>))";
final String string = "http://www.example.com\n"
+ "http://www.example.com/test\n"
+ "http://example.com/test\n"
+ "www.example.com/test\n"
+ "https://www.example.com\n"
+ "<a href=\"http://www.example.com\">http://www.example.com </a>\n"
+ "<a href=\"http://www.example.com/test\">http://www.example.com/test </a>\n"
+ "<a href=\"http://example.com/test\">http://example.com/test </a>\n"
+ "<a href=\"www.example.com/test\">www.example.com/test </a>\n"
+ "<a href=\"www.example.com/test\"><img src=\"www.example.com/test,jpg\" /></a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}