use strict;
my $str = '-- Here is some comment {!0-goal!}. Regex shouldn\'t match that!
{!1-goal!}
Here is some text and {!3-goal!} and some {!4-goal!}
It can be also as complicated as {!5-goal {!6-goal!} {!7-goal!}!}
Any thoughts?';
my $regex = qr/^(?!--).*(\{![^!]*!\})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}