$re = '/\[\((.*?)\)(.*?)\]/s';
$str = '\'[(id,name,top,left,width,height,depth)filename][(id,name,top,left,width,height,depth)filename]\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);