package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a.*\shref=[\"\'](?:(?:\w+)://)*((?:[\w-]+\.)+(?:[\w-]+))(?::\d+)?(?:/|$)?(?:[^\s]+)?[\"\'].*>`)
var str = `<a href="http://www.pochta.ru">Почта</a>
<a href="http://top100.rambler.ru/top100/All/rate21.0.shtml.ru"><img src="http://pics.rbc.ru/img/ver99/counter_rambler.gif" alt="Rambler's Top100 Service" width=88 height=31 border=0></a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}