#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "background-color:\s(?:"(.+)"|(?!url)(\w+)|url\(.+\) (.+?)\s)"
Local $sString = "background: "green"" & @CRLF & _
"background: url("big_green.png")" & @CRLF & _
"background: green url("big_green") no-repat" & @CRLF & _
"background: url("big_green") green no-repeat" & @CRLF & _
"background-color: "#fff"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")