const regex = /background-color:\s(?:"(.+)"|(?!url)(\w+)|url\(.+\) (.+?)\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('background-color:\\s(?:"(.+)"|(?!url)(\\w+)|url\\(.+\\) (.+?)\\s)', 'g')
const str = `background: "green"
background: url("big_green.png")
background: green url("big_green") no-repat
background: url("big_green") green no-repeat
background-color: "#fff"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}