using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(\btree\b)(?>(?!(?1)).)*?\bhouse\b";
string input = @"the tree is green. a tree house. a new house would be great. here is a tree with a house.
a Tree house in a tree.
here is a tree
with a house
a tree in a house?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}