using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\(\[)\d{7}(?=\]\))";
string input = @"[15211Z: 2012-09-12] ([5202900]) this matches
[15211Z: 2012-09-12] [5202900] this doesn't match !";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}