$re = '/(?<=\(\[)\d{7}(?=\]\))/';
$str = '[15211Z: 2012-09-12] ([5202900]) this matches
[15211Z: 2012-09-12] [5202900] this doesn\'t match !';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);