$re = '/(?<=:keyword_start:).*?(?=:keyword_end:)/';
$str = 'This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: This is also multiple space but this won\'t be replaced :keyword_start: this is the second content with double spaces :keyword_end: ... more text';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;