package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{{#each\s(\w*\s)in\s(\w*)}}`)
var str = `{{#each item in model}} kldnmflk sdjkn
{{#each item in model}} l;dfmgk;s
;d'sl,g
dsd
{{#each item in model}}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}