// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{{#each\s(\w*\s)in\s(\w*)}}").unwrap();
let string = "{{#each item in model}} kldnmflk sdjkn
{{#each item in model}} l;dfmgk;s
;d'sl,g
dsd
{{#each item in model}}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}