const regex = /(([1-9]{0,1}[0-9]{0,2}|2[0-4][0-9]|25[0-5])\.){3}([1-9]{0,1}[0-9]{0,2}|2[0-4][0-9]|25[0-5])\/([1-2][0-9]|3[0-1])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([1-9]{0,1}[0-9]{0,2}|2[0-4][0-9]|25[0-5])\\.){3}([1-9]{0,1}[0-9]{0,2}|2[0-4][0-9]|25[0-5])\\\/([1-2][0-9]|3[0-1])', '')
const str = `192.168.10.0/24`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}