import Foundation
let pattern = #"(<br)\b[^>]*?(?= *\/?>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<br id="foo" style="display:none">
<spam id="bar">sometext</span>
<br id="bun" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)