using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!.*\/{2})(?!.*\.{3})^[A-Za-z\/\.]*$";
string input = @"aaa/asdasda/adada/../.././";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}