re = /[^\};\{]+\{\s*\}/
str = '.selector-with-statements{border:none;}.selector-without-statements{}.etc{}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end