use strict;
my $str = 'http://wheaton.com/skin/media/main.js
https://wheaton.com/skin/media/main.js
http://www.wheaton.com/skin/media/main.js
https://www.wheaton.com/skin/media/main.js
http://wheaton.com/media/media/main.css
https://wheaton.com/media/media/main.css
http://www.wheaton.com/media/media/main.css
https://www.wheaton.com/media/media/main.css
http://wheaton.com/skin/media/main.png
https://wheaton.com/skin/media/main.jpg
http://www.wheaton.com/skin/media/main.jpeg
https://www.wheaton.com/skin/media/main.gif
http://go.wheaton.com/skin/media/main.png
https://go.wheaton.com/skin/media/main.jpg
http://go.wheaton.com/skin/media/main.jpeg
https://go.wheaton.com/skin/media/main.gif
';
my $regex = qr/https?:\/\/(?:www\.)?([-a-zA-Z0-9@:%._\+~#=]{2,256})(\.[a-z]{2,6}\b)*(\/[\/\d\w\.-]*)*(?:[\?])*(.+)*/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}