import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z][a-z]+)\\/([A-Z][a-z]+)\\/([A-Z][a-z]+)";
final String string = "www.domain.com/site/pool%2FPage%2FExample%2FTest";
final String subst = "$1/$2/$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}