package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\.?!\r\n]*)`)
var str = `Australians go hard!!!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}