$re = '/[A-Z0-9]+/';
$str = 'First \\"string\\" 1is "Hello \\"WOrld\\"!" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);