const regex = /msg-type="(?!(?:JOIN|INFO|TOPIC))[^"]+"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('msg-type="(?!(?:JOIN|INFO|TOPIC))[^"]+"', 'gm')
const str = `msg-type="codePRIVMSGcode"
msg-type="PRIVMSG"
msg-type="PRIVMSGcode"
msg-type="codePRIVMSG"
msg-type="codeJOINcode"
msg-type="JOIN"
msg-type="JOINcode"
msg-type="codeJOIN"
msg-type="codeTOPICcode"
msg-type="codeINFOcode"
msg-type="PRIVMSG"
msg-type="OTHER"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}