re = /^[+-]?(?:\.\d+|\d+(?:\.\d+)?)$/m
str = '234.2344
+.3456468
5.34.0
4+345.0 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end