using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\\\text\s*\{[^{}]*}";
string input = @"\\text { c. } 50 \\times 14
\\left. \\begin{array} { l l } { \\text { b) } 2 \\frac { 1 } { 5 } \\div ( \\frac { 4 } { 5 } - \\frac { 1 } { 4 } ) } & { } \\\\ { \\text { b) } \\frac { 1 } { 4 } - \\frac { 3 } { 4 } ) } & { } \\end{array} \\right.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}