$re = '/^(\w\s*){7,}\w$/m';
$str = 'Abcd1234
Abcd 1234
Abcd1234
Abcd1234 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);