#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?<=name=A_)([^\_]+)_([^\_]+)_([^\_]+)_([^\_]+)"
Local $sString = "http://www.test.com/?name=A_B_C_D_E_F&gclid=something" & @CRLF & _
"http://www.test.com/?name=A_first_second_third_fourth_fifth&gclid=something"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")