use strict;
my $str = 'http://www.test.com/?name=A_B_C_D_E_F&gclid=something
http://www.test.com/?name=A_first_second_third_fourth_fifth&gclid=something';
my $regex = qr/(?<=name=A_)([^\_]+)_([^\_]+)_([^\_]+)_([^\_]+)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}