import re
regex = re.compile(r"^(?:https?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\/\n]+)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("http://mplay.google.co.in/sadfask/asdkfals?dk=10\n"
"http://lplay.google.co.in/sadfask/asdkfals?dk=10\n"
"http://play.google.co.in/sadfask/asdkfals?dk=10\n"
"http://tplay.google.co.in/sadfask/asdkfals?dk=10\n"
"http://www.google.co.in/sadfask/asdkfals?dk=10\n"
"http://www.google.co.in:8080/sadfask/asdkfals?dk=10\n"
"http://username:password@hostname/abcd/foo")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")