using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*\n\n((^>+\s{1}.*$)+\n?)+)";
string input = @"and again
2016-05-06 14:27 GMT+03:00 serg radzishevsky :
> ok cool comment #2
>
> 2016-05-06 14:24 GMT+03:00 Sergey Radzishevsky :
>
>> first comment
>>
>> *Lorem Ipsum* is simply dummy text of the printing and typesetting
>> industry. Lorem Ipsum has been the industry's standard dummy text ever
>> since the 1500s, when an unknown printer took a galley of type and
>> scrambled it to make a type specimen book. It has survived not only five
>> centuries, but also the leap into electronic typesetting, remaining
>> essentially unchanged. It was popularised in the 1960s with the release of
>> Letraset sheets containing Lorem Ipsum passages, and more recently with
>> desktop publishing software like Aldus PageMaker including versions of
>> Lorem Ipsum
>>
>> --
>> *Sergey Radzishevsky*
>>
>> [image: Facebook page] [image:
>> Twitter account] [image: Dribbble
>> account] [image: Github repository]
>> [image: Linkedin account]
>>
>>
>> *Skype*: * radzserg*
>>
>>
>
>
> --
> Best Regards
>
> Radzishevsky Sergey
>
> *Skype: radzserg*
>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}