using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CCDBNUM=""([^""]+)""";
string input = @"String str= ""<decision CCDBNUM=""1111111"" adddate=""20180112""><decision CCDBNUM=""2222222"" adddate=""20180114"">"";
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}