const regex = /(sort=.*?&)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(sort=.*?&)', 'g')
const str = `category_id=249&sort=name&category_filter=15&`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);