$re = '/\d{5}(?(?=-)(-\d{4})|(?=a))/m';
$str = '11111a
22222b
33333-
44444-4444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);