import re
regex = re.compile(r"^(.{3})(.{3})(.{4})$")
test_str = "7882347812"
subst = "$1.$2.$3"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)