$re = '/Time[^\n]*\n((?:(?!Time|aaa)[^\n]*(\n|$))*(?=Time|$))|(?<=\n)(?!Time|aaa)[^\n]+\n/s';
$str = 'Time 00:00:01
kkk
lll
aaa
...
Time 00:00:03
kkk
kkk
kkk
lll
lll
aaa
aaa
...
Time 00:00:04
kkk
lll
...
Time 00:00:04
kkk
lll
...';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;