import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d){3}\\.?\\1{3}\\.?\\1{3}-?\\1{2}";
final String string = "000.000.000-00\n"
+ "111.111.111-11\n"
+ "222.222.222-22\n"
+ "333.333.333-33\n"
+ "444.444.444-44\n"
+ "555.555.555-55\n"
+ "666.666.666-66\n"
+ "777.777.777-77\n"
+ "888.888.888-88\n"
+ "999.999.999-99\n\n"
+ "00000000000\n"
+ "11111111111\n"
+ "22222222222\n"
+ "33333333333\n"
+ "44444444444\n"
+ "55555555555\n"
+ "66666666666\n"
+ "77777777777\n"
+ "88888888888\n"
+ "99999999999\n"
+ "99999999999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}