# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d){3}\.?\1{3}\.?\1{3}-?\1{2}"
test_str = ("000.000.000-00\n"
"111.111.111-11\n"
"222.222.222-22\n"
"333.333.333-33\n"
"444.444.444-44\n"
"555.555.555-55\n"
"666.666.666-66\n"
"777.777.777-77\n"
"888.888.888-88\n"
"999.999.999-99\n\n"
"00000000000\n"
"11111111111\n"
"22222222222\n"
"33333333333\n"
"44444444444\n"
"55555555555\n"
"66666666666\n"
"77777777777\n"
"88888888888\n"
"99999999999\n"
"99999999999")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.