using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(((https?|ftp|dict):\/\/|www\.)[^'"">\s]+\.[^'"">\s]+)(?=\s|$)(?![""<>])";
string input = @"my foobar http://www.google.com sfgsdg
my <a href=""http://www.google.com"">bla</a>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}