re = /\b(((https?|ftp|dict):\/\/|www\.)[^'">\s]+\.[^'">\s]+)(?=\s|$)(?!["<>])/i
str = 'my foobar http://www.google.com sfgsdg
my <a href="http://www.google.com">bla</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end