const regex = /<a(?:\s+[\w:-]+(?:\s*=\s*(?:(?:"[^"]*")|(?:'[^']*')|[^>\s]+))?)*\s*(?:(value)\s*=\s*(?:"([^"]*)"))(?:\s+[\w:-]+(?:\s*=\s*(?:(?:"[^"]*")|(?:'[^']*')|[^>\s]+))?)*\s*>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a(?:\\s+[\\w:-]+(?:\\s*=\\s*(?:(?:"[^"]*")|(?:\'[^\']*\')|[^>\\s]+))?)*\\s*(?:(value)\\s*=\\s*(?:"([^"]*)"))(?:\\s+[\\w:-]+(?:\\s*=\\s*(?:(?:"[^"]*")|(?:\'[^\']*\')|[^>\\s]+))?)*\\s*>', 'gmi')
const str = `<p>
<a readonly href="blah" value="page({page: '23032092'})" data-attr data-value='he-asd90lo' data-value-two="2">Link Here</a>
<a readonly href="blah" value="page({page: 23032092})" data-attr data-value='he-asd90lo' data-value-two="2" ng-if="abc 0 && abc 0">
<a></a>
<a ></a>
<a readonly
></a>
<a
></a>
(?:\\s*=\\s*(?:(?:"[^"]*")|(?:'[^']*')))
</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}