#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "C(at){2,}"
Local $sString = "Now we are looking for the pattern of a capital "C" followed by the letters "at" repeated two or more times." & @CRLF & _
"This pattern will not match "Cat" since the "at" is not repeated." & @CRLF & _
"It will match the first five letters of "Catatonic" since that fits our pattern." & @CRLF & _
"It will not match "catatonic" because the "c" is not capitalized."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")