import Foundation
let pattern = #"C(at){2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Now we are looking for the pattern of a capital "C" followed by the letters "at" repeated two or more times.
This pattern will not match "Cat" since the "at" is not repeated.
It will match the first five letters of "Catatonic" since that fits our pattern.
It will not match "catatonic" because the "c" is not capitalized.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)