import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a class=\"mention\" .*?data-user-id=\"([^\"]*)\".*>";
final String string = "<p><i><a class=\"mention\" data-mention=\"@test \" data-user-id=\"2\" href=\"https://backend.test/cp/employees/2\">@test </a> </i></p>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}