#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^role\s*[:]\s*(?!rolename)[\w]+)((,(?!rolename)[\w]+)*)$"
Local $sString = "role: rolenam1,common,app,web,rolenam2,db,rolenam3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")