using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\bwhole\b)((?:_|\b)whole(?:_|\b))";
string input = @"whole_anything
anything_whole
anything_whole_anything
anythingwholeanything
whole
whole_
_whole
_whole_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}