// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Profile\/(\d+)[\S\s]*Allan[\S\s]*AddAnswer(\d+)").unwrap();
let string = "<h4><a href=\"/Profile/23423423423.html\">@@@@@@</a> </h4> said12:49:32
</div>
<a href=\"javascript:void(0)\" onclick=\"replyAnswer(@@@@@@@@@@,'GET','');\" class=\"reportLink\">
report </a>
</div>
<div class=\"details\">
<p class=\"content\">
Hi there, Allan.
</p>
<div id=\"AddAnswer1234523453245\"></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}