using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+)\h+(?=\1)";
string input = @"Cher Cher
foo bar baz
Humphry Bogart Humphry Bogart
Edgar Allen Poe Edgar Allen Poe
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}