$re = '/^([1-9]\d*|d{1,3}|0)(.\d*|d{1,3})$/m';
$str = '30.117';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);